UNABLE TO MAKE JIO VIDEO CALLS IN INDIA

HI,

I AM USING JIO OPERATORIN INDIA, BUT I AM UNABLE TO MAKE THE NATIVE VIDEO CALL SUPPORTED BY JIO VOLTE.

IS THERE ANYTHING I AM MISSING OR THIS FEATURE IS ABSENT IN THE PHONE?

PLEASE HELP ME.

THANKS.

Comments

  • Black shark 2 doesnt support volte

  • But the flipkart website had shown that it supports 4GVOLTE.

  • jayanta.karmakar flysmart.ap I don't have sim cards added to the phone yet but could you try this:


    Go to settings, network or sim settings, click network type and change it to 4G, click enable enhanced LTE. Put airplane mode and back. 

    or

    Settings > Mobile networks > Turn on VoLTE call.


    Also, have you installed the Jio voice app?

  • Everything is done. Still no success. Btw, what's this user controlled PLMN? Never saw. Is this something we need to edit?

    Jio voice app too unable to make Jio video calls. I had installed and then checked and uninstalled.

  • edited June 9 #5

    I finally got it to work. Please give me some time need to get to 💻 @jayanta.karmakar @flysmart.ap

  • Ok, So i have tried and tested this multiple times. The end result is clearly reproducable.

    Firstly, let me start by saying that Black shark 2 is definitely VOLTE compatible. That too on both the sim slots.

    I have used my Jio sim card on both Slot 1 and slot 2. And I am able to do video calls from the regular phone app. NO need of the Jio4GVoice app.

    But unfortunately there is a catch.

    Before we go ahead, you need to make sure:

    1. You have the latest variant of the Jio 4G sim card. Doesn't have to be brand new, it can be an old one from your previous phone but must be purchased in the last 1 year.
    2. The caller must have the same Jio network based card with Volte enabled and can receive video calls.
    3. You are ready to be frustrated at the end lol

    Well, I started testing, checking, fiddling with the settings of the phone since yesterday. I had even disabled the second sim to towards the end to see if that changes the result, but it does not. No need to root the phone to see it work.

    Apparently, the fix is really really simple.

    Step 0: Open the phone app, click on the name of the contact, and you will see an invite icon instead of the video call icon.

    Step 1: Go to settings > network and internet> mobile network> Jio /Ind-Jio.

    Step 2: You must see the Enhanced 4g lte mode enabled. Disable it, wait for a minute and Enable it again

    Step 3: Close the phone app and open it again, click on the name of the contact and inside, you will find the video icon instead of the invite icon.


    Now here is the frustrating part I was warning you about:

    This will only fix the issue till the time you are online with internet enabled.

    As soon as you disable mobile internet, (even if you have the Enhanced 4G lte selected), the option will not stick and reverts back to non volte mode for some reason till you disable & enable it again.

    I have read multiple forums online and even called the JIO customer support (which was utterly useless). Support said that Xiaomi Black Shark 2 Skywalker is not registered in the TOOLS and database & hence they cannot comment on it.

    They could not even freaking log a ticket about it!

    Eventually, it has something to do with the phone not being able to register IMS settings and stick to them after reboot. Not sure if this is a network issue or software issue.

  • That's great. I will give it a try tonight once I go home. And to answer your question, it's an Software glitch not a hardware issue.

  • Tried. But didn't work for me. I am planning to return it to flipkart. Raised return request.

  • At last I am returning this phone to Flipkart for my money refund.

    Even the MI customer care executive has also agreed this phone supports 4GVOLTE but doesn't have the feature of Jio Video call.

    Thank God, I am switching to One Plus 7. Bye.

Sign In or Register to comment.