Black shark DEAD

Guys, I need your help.
Yesterday during use my BS1 turned off the screen and got the back logo (S) lit and does not respond to any command, I tried the hard reset and unsuccessfully. The device is still off and with the led on, already put to charge, already put on the computer usb and BS1 is still dead. How can I fix this? Has anyone had this problem?


Comments

  • press power + volume down together ( 5-10s)

  • When you say you tried to hard reset, I think you mean that you pressed the power button for like 20 secs right?

    Does the phone vibrate when you keep the power button pressed for 20 secs?

    If yes, and you still dont see anything on the display, you might want to show it to a service center as the screen might be dead.

    If no, then your phone is stuck in a kernel loop. Let it completely drain out of battery and then charge it again.

    (Also, try to remove the SIM cards from the slots and try to reboot)

  • edited November 13 #4
    I've done it and the device is still unresponsive. Can anybody help me?
    


  • @AdautoCesar, so when you drained the battery completely the S logo light turned off right? When you charged it fully again the S logo started to glow again (after pressing the power button again)? Or does it stay off now? If it is on and you connect it to a computer is there any reaction on the computer?

  • No, after the S went out and reconnected in the charger it did not rise again. Today when I connect to the charger or the usb of the pc it turns the front red led but does not respond to any command.
    


Sign In or Register to comment.