Asphalt 9 dosent work on my Balck shark2 (solved)

2

Answers

  • Hi Div,

    i got old too :).

    i'v done exactly what you said, deleted both files .obb and clear the cache of google play, then started the game, but nothing happens, the game closed again as in the previous video, it didn't look for any missing files.

    im wondering if is there any restrictions for some countries to play this game?

    thanks

  • edited June 2019 #12

    You have got to be freaking kidding me. It did not launch then too? What the heck!

    Game restrictions hmmm, no bro I don't think so. It did have a worldwide launch as far as I remember.

    If it did, it would have also either showed up 1) on play store by a warning message and no install button, or 2) launch and gave an error >_<

    Worst part is I am on black shark 2 and it runs smooth as butter on it, so it is not even a device restriction.

    Can you install parallel space app from play store and open asphalt 9 from the second space?

    This should eliminate any existing app restrictions causing it to crash.

    If that does not work too:

    download.apkpure.com/b/apk/Y29tLmdhbWVsb2Z0LmFuZHJvaWQuQU5NUC5HbG9mdEE5SE1fMTAxMjhfOWI5YzEzNzM?_fn=QXNwaGFsdCA5IExlZ2VuZHMgMjAxOSBzIEFjdGlvbiBDYXIgUmFjaW5nIEdhbWVfdjEuMC4xYV9hcGtwdXJlLmNvbS5hcGs&k=06d71f908479f35a69e20896cd69025a5d14acc1&as=90981c2110a0a7168af7c299a476bd405d120a39&_p=Y29tLmdhbWVsb2Z0LmFuZHJvaWQuQU5NUC5HbG9mdEE5SE0&c=2%7CGAME_RACING%7CZGV2PUdhbWVsb2Z0JnQ9YXBrJnM9NTA5OTgwMjQmdm49MS4wLjFhJnZjPTEwMTI4&hot=1

    Can you uninstall that and try to install this one? It is the very first version of the game. Let me know what happens.

  • I also don't think its related to your country or anything like that. From my experience sometimes searching for a solution of a weird bug like that is more difficult than to just start from the beginning: a factory reset. Usually that should fix the issue. Just backup your data as this obviously wipes the phone. Obviously that's just the last way out but looking at the history so far that actually could be a shortcut.

  • Factory reset?

  • Hi Div,

    i already have parallel space installed, i opened the game from inside parallel space, then the game ask to download update 593MB, downloaded the update then started the game, another message appear asking about check license and get the game, get the game took me again top the play store, in the play store i have only the option to open the game and when open it it makes the same problem. as in the below link.


    also i already have Asphalt8 installed and working properly.


  • Hi InMem

    i already did the factory reset from the day 1 the game didnt work and had the same result.

    thanks

  • edited June 2019 #17

    eleraki.mahmoud I am so sorry to be a complete jackass. I forgot the name of the application. I meant "Island" from the playstore.

    When you download Island, it will create a work profile. Let it set up.

    Then open the app and go to the "Mainland". Click on Asphalt 9. At the bottom, you will see a + icon. Click on that to install the application in another space (that is why I was stupidly thinking of the parallel space app)

    *** NOTE: If you launch the application now, you will get that license check error. ***

    There is one last step. In the "Island", you will see Google Play store. Open that and log in/Sign in.

    After you do that and playstore loads, remove everything from the recent apps.

    Go back to the menu and load the Island version of the application.

    P.s thanks a bunch for providing the videos. Helps out a lot!

    Also, the link that I provided was for the first version of Asphalt 9. I know that 8 works on your phone, you already told me that lol.

  • edited June 2019 #18

    I remember I had the same license error on my old phone. I tried it again on Black shark 2, and I was right I had forgotten to log in to the Playstore and got it again lol.

    (Parallel space never worked for me or my friends. that is why I had switched to Island. I am sorry for the earlier post where I mentioned it)

    This is what I was talking about in the note. So you must make sure to complete all the steps above. After I log in to playstore, the game works fine. It brought me to a new fresh start screen with the age and other details to fill

  • Hi Divyaansha,

    ur not got old man, you still working around. thanks 4 ur help.

    well, i've done all the previous steps.

    1- setup island.

    2- tried to setup aspalt9 from the main land, but the android installer is open but couldn't set it up.

    3-i logged in using google account in island app, the go back to main land tried to set up aspalt9, but the installer couldnt do it.

    4- i went directly to the play store from island app and installed asphalt9, it didnt took time.

    5- i lunched asphalt9 fron inside the island app but the same result found, didnt launch.

    please see the below videos and check if i did it correctly or iam mistaken.

    thanks



  • No there is nothing you did wrong. It is just that.. if you noticed, when you were trying to install it from the existing apk on the phone, it was not installing.

    No matter how many times you clicked install, it brought you back to the install page.

    Even in the second scenario, when you went to the play store, it downloaded so quickly.. as if it was finding the apk in the temporary files of the phone.

    Can you uninstall it completely and try this one



Sign In or Register to comment.