Asphalt 9 dosent work on my Balck shark2 (solved)

edited July 2019 in Support

dear black shark team,

please, Asphalt 9 dosent work on my device black shark 2 version SKYW1903272OS01MP1, once installed it appears in shark space but when open it come back to home screen (doesn't lunch).




  • Hi eleraki.mahmoud,

    Is the issue resolved yet?

    Have you tried reinstalling the game?

    Does the game app have the proper permissions? You can check this by long pressing the game icon and going to App info or going via settings to the app. You will see permissions tab/section. See if the app has all the necessary permissions.

    Also, does the app work outside the Shark space? Could you please try launching the app outside the Shark space section?

    Please try it and let me know

  • edited June 2019 #2

    Hi Div,

    thanks for reply, i tried every think you can imagine but no response, the game even has no error message appear to diagnose the problem. i tried installation many time in different ways, from the store and by downloading the files from different sources and by transferring using shareit from my friends mobiles that the game working with them, but all are failed.

    now i have another problem, when trying use GPS always giving no GPS signal.

    im really disappointed


  • Wow that is sad. Are you on the Chinese rom or the Global Rom?

    Is there a chance that you can get the phone replaced? How about other games, do they work?

    Has the GPS issue started after the most recent update? Waiting for your reply.

  • Can you send me a screenshot of the app storage.

  • edited June 2019 #5

    Hi again Div,

    im in the global version.

    i installed asphalt 8 and its working with no problems, also PUBG is working but when i receive whats-app call the game restart from the beginning.

    now im installing asphalt 9 again and i will send you a screen record for whats happening.

    for the GPS issue is still exist even after the update, im now on the last soft version SKYW1905210os01MP2

    is the dark mode is fully working with you?


  • I am gonna go mad with this difference in the update versions, but glad to know you are on the latest version for your region.

    Nope, I do not have Dark mode at all. Zero, None!

  • Could you make a screen record for whats happening?

    (You can upload it to YouTube and then insert the link in the comment bar)

  • @eleraki.mahmoud I faced a similar issue where I downloaded Honkai Impact 3d and played it. At first it was fine but when I added it to the Shark space, it was giving me an issue where if I launch it, it loaded with a blank black screen.

    I removed it from Sharkspace, when to the app from the normal home page and it was still giving me the black screen of death!

    I went to the app in the settings and cleared the cache. That is when it started working again.

    I am eagerly waiting for your recording too to see what is going on. But most probably it has something to do with the settings or something. Please do let me know

  • Hi again,

    the screen recording in the below link.

  • @eleraki.mahmoud @Davon.z

    Thank you for the video.

    Ok, I am trying to wrap my head around this and seeking for the easiest possible explanation that does not involve root. I am getting too old for working with non rooted phones lol

    How precious is data for you?

    If you have a wifi connection, could you please try 2 things. (I know I know you have tried something like this before T_T)

    1. Delete both the obb files
    2. Go to Google Play Games app and clear the cache under storage.

    Now load the game and let me know if it starts to download the missing files <<-- this is what I am looking for.

    (I want to see if it still force closes on you without the obb files)

    Fingers crossed.

Sign In or Register to comment.