PLEASE HELP, music lights stopped working after player added to game launcher

edited September 2 in Support

PLEASE HELP

sorry for the uppercassing

i primarily using poweramp as my music player

i just added poweramp to the shark mode because i want to access it and play game while listening to music.

it works perfectly with the light visualization on the phone when in normal mode.

then i notice the music light's not working on shark mode. and when i switch back to normal mode IT'S STILL NOT working. then i switched back to the shark mode and remove poweramp from the game list, then go back to normal mode, still no luck.

WHAT I HAVE TRIED :

1. Restart phone

2. Reinstall spotify

3. Disable and reenable light effect

I HAVE ALSO TRIED to clear the shark mode data, but what i notice here my added app that originaly not appearing on game mode still there after i clear the data, but the tutorial is appearing again.

THE PROBLEM IS i think that this phone still recognise poweramp as game so it dont give respond to the output.


is there a way to completely reset game mode and reset the app list? maybe that will fix this problem, any help would be appreciated, especialy from devs. thanks


more info : i tried the same thing with spotify because of my curiousity and the same exact thing happen so yes this is not poweramp's fault

Tagged:
«1

Comments

  • Did you clear the data and cache of blackshark, Gamedock and game launcher and gamesdkmanager, I think those are all the apps tied to sharkspace.

  • What phone are you using? Black Shark 1 , 2 or 2 Pro?

    What OTA or what OS version are you on? Global or China?

    I have a BlackShark 2. Let me try on that meanwhile you answer.

  • edited September 4 #3

    Ok, So I tested it. And you are right.

    When I play spotify and Poweramp on the normal phone launcher it has the RGB lights.

    When i add it to the Sharkspace, Side lights does not work. But I found a solution.


    **Solution**

    Issue : Sharkspace thinks of the music players as a game.

    Steps:

    So you need to slide the gamedock, Click on Spotify - Gamer Studio Or Poweramp - Gamer studio on the very top. That will open the game studio settings like performance, display, touch etc.

    At the bottom, there is something called Multi-experience. Click on that.

    Enable Athletic light. THAT IS IT. it works! (This has to be done for both music players as they are treated differently)

    Now, when you play it outside or inside of Sharkspace, the lights will work.

    P.s. Randomly: If you are outside Sharkspace and play the app, and the lights do not show, just drag the gamedock once from the top and they will be back.


    -----------------------------

    That being resolved, there is still one issue I am struggling to resolve. Once I delete Spotify or Poweramp from the Gamelist, the lights stop to work no matter what I try.

    Working on a solution for this. Will give you an update once I do

  • hey Link

    i have tried to do this but still no luck, doing that doesn't seem to reset the game list on the shark mode

  • hello, sorry i forgot to mention it, my phone is blackshark 2 running on latest version of global rom

  • thanks for the reply and solution

    but i can't find that "multi experience" option. am i missing something? or is it because i'm using global version? i'm also trying to show it on other app and i'm pretty sure that the options are same for every app) i'm already on the latest update for global version (SKYW1907110OS00MP3)

    and my main problem is same like you. "Once I delete Spotify or Poweramp from the Gamelist, the lights stop to work no matter what I try."

    i have reached developer for this issue and still waiting for their solution, i will share it here if i have found the solution for this

    also please update if you also find solution for the issue thank you

  • edited September 4 #7

    @Juansong427 you have to head into the gamer studio to find the "Multi experience" option. In your screenshot you swiped out the GameDock (this is not the gamer studio yet) - I know this doesn't look like a button and I tried to feedback that already a couple of times... Anyway: You have to klick the text (in your screenshot click on : "DraStic - Gamer Studio"). This will bring you into the real Gamer Studio. Each "game" has their own Gamer Studio.

  • Will do. :)

    You also let me know if that game studio workaround works for you.

    Do what @InMemoriam said. Click on that top icon

  • damn, all this time i don't know that it's a button lol, thanks for the information

  • it works but the light only works when the app is opened, but that's still better than no light at all, thank you very much

Sign In or Register to comment.