Home Launcher Accessibility Fix

I really dont like the bug about the accessibility so I decided to contact the Nova Devs team hoping to get an answer or maybe they can make a patch on their app but I decided to look at this matter on my own.


In my issue when I press the home button successively it would ask me to re-enable the accessibility with that in mind, I noticed that Long Press for Home Button activates the assist and voice app so I thought maybe that is whats interfering with the Nova Launcher and heres how I did it.


1. Go to settings

2. Then Apps & Notifications

3. Default Apps

4. Select "Assist & voice input"

5. Select "Assist App"

6. and press the on the google icon

7. Select "none"

8. Go back to Home Screen and test it out


Ive been pressing the home button for like 100 times now and it never asked for accessibility.


I tried using the Shark Space, play for a few minutes and turn off Shark Space it still ask to choose the home launcher but I didnt asked for accessibility. I'm 95% sure I fixed it, need someone else to confirm

Comments

  • I hardly ever run into that specific accessibility issue that u describe for whatever reason (obviously if accessibility service for nova launcher is deactivated). Consecutively pressing the home button hardly ever asked me for the accessibility (I think it happened once or twice but yea hardly ever). I also use long press for google assistant (also didn't ask me for accessibility) but I love that feature and wouldn't want to miss that tbh. I do use the "swipe up" gesture from "anywhere" on the screen to access recent apps. This needs accessibility services and always asks me when I restart the phone. That the accessibility services get cleared on a reboot is apparently stock android behavior...

    Anyway I'm happy you found a solution that fixed your main problem with nova launcher. I use a BS2 and not the pro so maybe thats also why we experience differences. The bug with exiting shark space is for sure present on all 3 devices (bs1,bs2,bs2pro).

  • its for those who use Nova Launcher, forgot to mention

Sign In or Register to comment.