Warriors of waterdeep bs1

I can't intall this off the play store, says its not compatible with this version.

Has anyone else had this issue?

I meet all the sys reqs so I'm unsure why I can't install, I checked with Google support and they suggested to approach the developer Ludia.


Just wondering if anyone has had this issue

Comments

Sign In or Register to comment.