Can't Charge BS2 (Moisture Issue) Now Have A Brick

BS2 has never been in touch with water etc. Got a moisture warning from the phone when connecting charger and wouldn't allow to charge.

Tried fixing multiple times from guides on YouTube but to an avail and ultimately BS2 now run out of charge.

Have left for 2 days now but can't get phone to charge or turn on.


Any ideas? Now literally have a £500 brick and believe it's a software fault!


Frustrating and need help ASAP. Thankyou

Comments

  • I kinda doubt a software issue? Maybe it was indeed somehow related to sweat in your pocket? But maybe its also a wrong error message and your charging port is somehow broken. I guess you already tried different cables and a different charger? If all that doesn't help I would try to replace the charging port and just give it to a service center?

  • Thanks for the reply. I have contacted support on here and got a speedy response but since providing purchase information it's all grinded to a halt.


    Just waiting for them to get back now as under warranty.

  • Well after trying every day for the past week or so. This morning we had normal life, charging as usual and back to life.



    Guess it just wanted a few weeks off.

Sign In or Register to comment.